Here are the system requirements you need in order to use Strattic.


WordPress 5.8 or Greater

Strattic works with WordPress version 5.8 or greater.

PHP 7.4

Strattic supports PHP version 7.4. Support for PHP 8.1 is on our roadmap but we don't have an ETA yet.

MySQL 5.7

Strattic works with MySQL version 5.7.

Compatible Plugins and Tools
Static WordPress sites work a little differently than traditional WordPress sites. After the static site is launched, it does not have a connection to the WordPress database.

This can affect native WordPress functionality, like advanced search filters and comments. Certain types of WordPress Plugins may also not function as expected with a static site. Learn more here

Browsers

As web technology develops, it’s important for users to keep their websites up-to-date. Older browsers may not support the full set of features provided by Strattic. Following is a chart of the systems that are supported by Strattic:

Browser

Version

Google Chrome

100.x and above

Microsoft Edge

100.x and above

Brave

100.x and above

Firefox

100.x and above

Safari

MacOS Safari 14 and above

Note: No versions of Internet Explorer are supported.

Did this answer your question?